SyncMate requires OS X 10.8.5 and higher and is compatible with Android 4.x-9.x devices and iOS 5.x-11.x devices.

 

Detailed information on compatible platforms can be derived from SyncMate product page at our website.